Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Longer than normal build times reported
Incident Report for Coveralls
Resolved
We have implemented the fist of several planned changes to hopefully improve builds times for the users who have been experiencing slow build times. We have planned additional changes for one evening this week and the coming weekend. If you're experiencing slower than normal build times, or have any questions, please reach out to us at support@coveralls.io.
Posted Nov 03, 2024 - 14:47 PST
Identified
The issue has been identified and a fix is being implemented and planned for a no-downtime window this evening. This issue continues to affect some customers and not others, but our fix should address longer build times for affected customers.
Posted Nov 01, 2024 - 08:30 PDT
Investigating
Several users have reported longer than average build times, either appearing as large number under a build's "BUILD TIME" or as builds staying in PENDING COMPLETION state for longer than expected. We are investigating the issue.
Posted Oct 31, 2024 - 14:08 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.