Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Slow performance reported
Incident Report for Coveralls
Resolved
We are closing this incident, not because it is resolved but because in order to resolve it, we must undergo unplanned maintenance. We will close the incident and open the maintenance window, from approximately 10p US PST to 2a US PST.
Posted Jun 29, 2022 - 22:00 PDT
Update
We have scaled infrastructure to address performance. We have not paused any outlier repos. Continuing to monitor.
Posted Jun 29, 2022 - 13:53 PDT
Monitoring
We've identified the cause of current performance issues and have addressed it. We'll now implement normal scaling procedure to drain background queues more quickly. Look for performance to start improving immediately, with normal performance likely to return in 1-3 hrs.
Posted Jun 29, 2022 - 12:24 PDT
Investigating
We are currently investigating reports of slow performance (slow build times) reported by several customers and borne out by their repo stats. We aren't seeing metrics that indicate a performance slowdown for expected reasons, so we are investigating. We will potentially pause outlier repos and/or manually perform DB maintenance tasks. During such time coveralls.io may be in maintenance mode for 5-10 minutes. If longer wait times are expected, we will put coveralls.io into read-only mode.

If you think your repo may be an outlier, you can email us at support@coevralls.io to verify.
Posted Jun 29, 2022 - 10:12 PDT
This incident affected: Coveralls.io Web.