Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

504 Timeouts (Resolved)

Incident Report for Coveralls

Resolved

This incident is resolved.

We have applied an additional layer of monitoring that should help us catch these cases earlier.
Posted Oct 10, 2025 - 12:00 PDT

Update

Based on the details of today's incident, we've added another layer of monitoring that should give us earlier indications of this error state and allow us to respond more quickly.
Posted Oct 10, 2025 - 09:46 PDT

Monitoring

We've received results of 504 Timeout errors from 7am PDT through 8:15am PDT. We have addressed the issue and issue was resolved as 8:19am PDT.

We are monitoring for further issues.
Posted Oct 10, 2025 - 08:23 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.