Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Processing delays for repos with 5K+ source files
Incident Report for Coveralls
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 14:22 PDT
Update
Continuing to monitor. Build times coming down for large repos. Fewer than five (5) repos now affected.
Posted Aug 24, 2023 - 11:49 PDT
Update
Build times have come down for large repos. We are continuing to monitor as associated queues clear.
Posted Aug 24, 2023 - 10:42 PDT
Monitoring
We've seen a spike in build times for large repos (5K+ source files). Right now, only nine (9) repos seem to be affected. We have implemented a fix and are monitoring as build times return to normal for these repos.

The root cause of this spike is elevated jobs (and therefore dequeue times) in queues dedicated to large repos which appears to have been triggered by two (2) repos sending an unusually high number of uploads over the past 1-3 hr period. We have increased resources to these queues to accelerate processing but may need to pause the above repos if uploads continue at the same level.

If you think your repo was affected you can reach out to us at support@coveralls.io. We will reach out to the owners of the repos with elevated jobs.
Posted Aug 24, 2023 - 09:56 PDT
This incident affected: Coveralls.io Web.