Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Slower performance due to backed-up job queues
Incident Report for Coveralls
Resolved
This incident has been resolved. All repos unpaused.
Posted May 26, 2022 - 15:00 PDT
Update
Queues cleared by 25%. Continuing to monitor.
Posted May 26, 2022 - 12:14 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2022 - 11:39 PDT
Investigating
We are again experiencing slower performance due to backed up job queues, which are normally due to a spike in general usage. However, instead of higher traffic in general, the usage seems to be coming from a few outlier repos. We are pausing repos with 200 or more jobs currently in queue. (We have a few repos with more than 1K jobs in queue at this moment.) If you think your repo was affected, you can reach out to us at support@coveralls.io. We will un-pause those repos as soon as we've cleared the queues by 80% for all other users and get performance back down to targets.
Posted May 26, 2022 - 11:17 PDT
This incident affected: Coveralls.io Web.