Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Intermittent outages
Incident Report for Coveralls
Resolved
We are closing this incident after monitoring and observing no further outages throughout the rest of the day.
Posted Jul 20, 2022 - 20:02 PDT
Update
We think we have resolved this issue, but we will continue to monitor for the next hour before closing this incident.
Posted Jul 20, 2022 - 12:37 PDT
Update
We are modifying configs and deploying new servers. Please allow 15-20 minutes for new server fleet to deploy.
Posted Jul 20, 2022 - 10:55 PDT
Update
We are still seeing intermittent outages without a known root cause. We are continuing our investigation.
Posted Jul 20, 2022 - 10:44 PDT
Monitoring
We have deployed new servers and continue to investigate the cause of intermittent outages with the previous servers. Website and API are fully operational at this time.
Posted Jul 20, 2022 - 10:05 PDT
Identified
We are deploying new servers and decommissioning problematic ones. Current outages should be resolved within 5-10 minutes.
Posted Jul 20, 2022 - 09:48 PDT
Investigating
We are receiving reports of intermittent outages of both the web app and the API. We are investigating.
Posted Jul 20, 2022 - 09:30 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.