Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Drop in coverage for some parallel pull_request builds

Incident Report for Coveralls

Resolved

This incident has been resolved.
Posted May 26, 2023 - 11:30 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2023 - 09:45 PDT

Identified

After a recent release, we have received reports of `pull_request` builds that have suddenly dropped in coverage with no change in CI setup.

Specifically, these builds have had several parallel jobs and now, suddenly, have only one job per build.

We are aware of the issue, have identified the root cause, and are working on a fix.

We will update this incident when status changes.
Posted May 25, 2023 - 13:42 PDT
This incident affected: Coveralls.io Web.