Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Github status updates failing intermittently
Incident Report for Coveralls
Resolved
We believe this incident has been resolved. Background job failures for Github status updates have largely stopped. If this issue is affecting you tomorrow, let us know at support@coveralls.io and we'll take further action.
Posted Apr 14, 2022 - 20:49 PDT
Monitoring
We are getting reports of Github status updates not arriving at Github for repos that have been fine in this regard for a long time. We are noticing an uptick in background job failures responsible for these status updates. In most cases, these failures resolve immediately by re-trying them. But some fail a few times before succeeding. We suspect there's an issue with the Github API (though not according to https://www.githubstatus.com/), or an isolated issue between coveralls.io and github.com, that's resulting in behavior like rate limiting. There is no known basis for actual rate limiting, but this is the effect.

Please know that any failing status updates will be retried in exponential back-off fashion (so they should eventually succeed) and that we are monitoring closely and will take any action we can to improve things.
Posted Apr 14, 2022 - 13:24 PDT
This incident affected: GitHub.