Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Delayed Coverage Calculations for Some Users

Incident Report for Coveralls

Resolved

All builds from today (Jun 3) have been processed. As background job queues cleared, build times returned to normal. We will continue monitoring.
Posted Jun 03, 2025 - 21:11 PDT

Update

We took the following action to more quickly restore normal build times for all _new_ builds today:

- We moved all unfinished background jobs from yesterday (Jun 2) into holding queues in order to restore normal build times for new builds from today (Jun 3).

- We scaled resources to more quickly drain the existing queues of jobs from new builds from today (Jun 3).

We will monitor progress on all new builds and provide updates here until we're fully caught up (zero (0) background jobs in queue).

Thanks for your patience in the meantime as we restore the best possible performance to the service.
Posted Jun 03, 2025 - 10:34 PDT

Monitoring

We are continuing to clear a backlog of background processing jobs for builds submitted in the past 18-24 hrs. While all systems are operational, there will continue to be latency on build times until we clear all background job queues, which are FIFO. Current estimate: 1-hour. We will post updates here until build times return to normal.
Posted Jun 03, 2025 - 08:33 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.