Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Missing build data in builds from last week?
Incident Report for Coveralls
Resolved
Closing this for now. Please try re-running any builds you think may have been affected last week, or reach and we'll be glad to help.
Posted Aug 27, 2024 - 12:37 PDT
Monitoring
We've had a couple of reports from customers about builds that were received by the Coveralls API prior to last week's outage (https://status.coveralls.io/incidents/mmg3wsghl3k5), which indicate they may not have been fully processed.

This would most likely be due to background jobs responsible for fully processing these builds getting caught up in service failures during our outage and, as a result, potentially, running out of retries and never completing.

If you think any of your builds may have been affected this way, we have two suggested remedies:

1) Re-run the build via our API > ReRun Build Webhook - Documented here: https://docs.coveralls.io/api-introduction#rerun-build-webhook, the ReRun Build webhook will re-process any existing build, including a full recalculation of all received coverage report data. Here's how to issue a rerun via the API (just substitute your "Build Number" and Repo Token):

curl --location 'http://coveralls.io/rerun_build?build_num=&repo_token=' \
--header 'Content-Type: application/json'

Note that `build_num` can be either the Build Number assigned to your build by your CI service, or the build's commit SHA per GitHub.

2) Reach out to us at support@coveralls.io - We'll be happy to re-run your build for you, or investigate further if rerunning the build doesn't resolve your issue.

Thanks to all customers for your patience with us last week.
Posted Aug 26, 2024 - 12:27 PDT