Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Elevated Latency

Incident Report for Coveralls

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 09:59 PST

Monitoring

About 45 minutes ago we started experiencing elevated latency for some repo types. We have scaled up and are monitoring as queues clear for those jobs. Coveralls remains fully operational. All builds should return to baseline in ~20-min.
Posted Feb 28, 2025 - 07:32 PST
This incident affected: Coveralls.io Web and Coveralls.io API.