We have received no further reports of 504 timeout errors on coverage report uploads today, but we continue to monitor and will continue trying to improve our mitigations.
Posted Oct 13, 2025 - 16:15 PDT
Monitoring
We have received some reports of 504 errors this morning. We are monitoring to avoid further occurrences.
We are looking into any gaps in our new monitoring regime, which has drastically reduced occurrences, to see where we can further improve.
Posted Oct 13, 2025 - 11:02 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.