Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Known Issue - Maintenance Window Required
Incident Report for Coveralls
Resolved
We have completed a key step in the resolution of the issue described here.
Posted Jun 30, 2024 - 06:30 PDT
Identified
We are working to resolve a known issue of Coveralls suddenly sending multiple PR comments to customer PRs, rather than one, updated PR comment that replaces older PR comments. This issue has been active for ~2.5 weeks.

Our solution involves the need to change a column type in a production database table to accommodate larger integer values.

With hundreds of millions of records and constant read/write activity, we will need to make this table change during a maintenance window scheduled for this weekend, Sat Jun 29-Sun, Jun 30.

We will attempt to perform our changes on Saturday evening US PDT, but will update this post when the exact window is known.

We will keep this "incident" open until the associated maintenance window has closed.
Posted Jun 28, 2024 - 18:00 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.