Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Login issues
Incident Report for Coveralls
Resolved
A fix has been implemented. We suspect this only affected a few users at once as a matter of coincidence. If this particular issue should ever affect you, here are some steps you can take to resolve the issue:

Steps to resolve "Infinite reauthorization loop via Github login":

If clicking Reauthorize (App) does not log you in:

1. Note the name of the app requesting reauthorization
2. Go to Github > Settings > Applications > Authorized Apps and Revoke authorization of the app.
3. In browser settings (Chrome), go to chrome://settings/cookies and click See all site data and permissions
4. Find coveralls.io and click trash icon to clear all cookies for coveralls.io
5. Go to coveralls.io and try logging in again.
Posted Jul 03, 2023 - 08:37 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 03, 2023 - 07:03 PDT
Investigating
Some users report not being able to login to coveralls.io. The behavior is a circular redirection landing on a Reauthorization required screen with error message:
> This application has made an unusually high number of requests to access your account. Please reauthorize the application to continue.

If you are experiencing this issue, please let us know at support@coveralls.io.
Posted Jul 03, 2023 - 06:54 PDT
This incident affected: Coveralls.io Web.