Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Reports of "Website under heavy load" errors

Incident Report for Coveralls

Update

We are continuing to monitor for any further issues.
Posted Aug 18, 2025 - 20:56 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 18, 2025 - 15:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 14:23 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 18, 2025 - 13:25 PDT

Investigating

We are investigating reports of this error which was first seen last week.

We believe this is an error being thrown by our HTTP server but has nothing to do with actual website load, which is currently normal.

If you receive this error, please re-try your request.
Posted Aug 18, 2025 - 12:25 PDT
This incident affects: Coveralls.io Web and Coveralls.io API.