Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Elevated Latency

Incident Report for Coveralls

Resolved

We have cleared all backed up jobs from this incident. Latencies are back in normal range; albeit normal for our highest-traffic days of the week (Wed-Thu, US workday).

For those following our efforts to address the latencies we've experienced over the last several weeks, this weekend and next represent our final planned efforts to address these issues. We expect the work over this weekend and next to resolve the occasional spikes in latency we've been experiencing, especially during periods of high traffic.

If you are still waiting for any of your builds created during this period (late Wed-early Thu, US) to complete, please reach out to us at support@coveralls.io and we will investigate to ensure they don't have other causes and are completed.
Posted Mar 13, 2025 - 09:17 PDT

Update

Latencies are back in normal range, but we continue to clear the remainder of backed up background jobs.
Posted Mar 13, 2025 - 08:51 PDT

Update

Backed up jobs are about 50% cleared. ETA to normal: ~10-min.
Posted Mar 13, 2025 - 08:36 PDT

Monitoring

Elevated latencies system-wide. We have deployed resources to clear the backup. ETA to clear: ~20-min.
Posted Mar 13, 2025 - 08:12 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.