Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Slow performance
Incident Report for Coveralls
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 20:01 PDT
Monitoring
We're experiencing some performance issues (slow build times).

As with our recent issue on Wed, Jun 15:
https://status.coveralls.io/incidents/krrc78mthkyb

We're not seeing the traffic levels we'd expect for this type of latency, so we are tracking metrics from our database layer and performing maintenance functions there that should improve build times.

At this point, we expect normal performance to return by end of business today, Fri, Jun 17. We have also planned maintenance for tomorrow, Sat, Jun 18, to fully implement all maintenance procedures that will improve database performance.

We have not paused any outlier repos, or scaled up our infrastructure, as this will only increase database requests and won't help resolve the issue.
Posted Jun 17, 2022 - 11:59 PDT
This incident affected: Coveralls.io Web.