Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Elevated Latency

Incident Report for Coveralls

Resolved

Performance in terms of latency of background jobs has been restored to normal. The only customers who may continue experiencing latencies are "outlier" customers with builds that exceeded fair use policies earlier this morning. Latencies on the secondary queues we use to process these excess jobs remains at about 40-min. If you wonder whether your latencies were caused by excess usage, reach out to support@coveralls.io and we'll confirm for you either way.
Posted Mar 10, 2025 - 09:49 PDT

Monitoring

We are monitoring the results of scaled resources. ETA 15-20 min.
Posted Mar 10, 2025 - 09:29 PDT

Identified

We have detected elevated latency during a period of high traffic. We are deploying resources to address and bring those down. ETA ~20-min.
Posted Mar 10, 2025 - 09:20 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.