Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Elevated Latency

Incident Report for Coveralls

Resolved

This incident is resolved. Performance normal for all new builds is normal. All jobs in backed up queues have been cleared with the exception of secondary and tertiary queues for outlier repos. We will be clearing those manually over the next several hours as traffic allows.
Posted Apr 30, 2025 - 13:33 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 30, 2025 - 12:51 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2025 - 12:19 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 30, 2025 - 11:35 PDT

Investigating

We are currently investigating this issue.
Posted Apr 30, 2025 - 10:19 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.