Closing this as it was intended to stay open for the week of Mon, Aug 1-Fri, Aug 5.
Posted Aug 07, 2022 - 07:26 PDT
Update
Keeping this incident open for another 24-48 hours in case users experience any of the issues below. If you're having any issues, please see the potential remedies below.
Posted Aug 02, 2022 - 07:53 PDT
Monitoring
We migrated the servers underlying our app again this weekend out of necessity.
All systems are fully operational, but for those of you who need to whitelist Coveralls IP addresses, the list is below.
Our DNS service is set up to make this change invisible to you, but for those of you who may be receiving 400 Bad Request errors back from Web or API requests, a guide to clearing the various caches involved in your chain of requests is also given below.
Finally, if you're experiencing these, or any other issues, we'd appreciate a heads up at support@coveralls.io.
Guide to clearing cache in your chain of requests:
If you are receiving 400 Bad Request errors, we think the root cause is caching somewhere in the chain of requests. Please try clearing your local caches with the help of these resources: