Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Service Disruption due to "Invalid SSL Certificate"

Incident Report for Coveralls

Postmortem

Incident: Service Disruption Due to Failed SSL Certificate Renewal

  • Date: January 22, 2025
  • Duration: 17 minutes (07:00-07:17 UTC)
  • Impact: Service interruption due to SSL certificate issue

Summary:
Coveralls experienced a brief service disruption when our automated SSL certificate renewal process failed. While our SSL certificates auto-renew 30 days before expiration, one unreachable server prevented the renewal process from completing successfully.

Timeline:

  • Prior to incident: Multiple automated renewal attempts unsuccessful
  • 07:00 UTC: Service disruption began
  • 07:17 UTC: Service restored after infrastructure adjustment

Root Cause:
The incident occurred when one server became unreachable during our SSL certificate auto-renewal process. While our certificates are configured to auto-renew, the renewal process requires successful deployment across our infrastructure. The unreachable server prevented this deployment, ultimately leading to an outage due to “certificate expiration.”

Resolution:
We identified and removed the problematic server from our infrastructure, allowing the SSL certificate renewal and deployment to complete successfully.

Preventive Measures:

  1. Enhanced monitoring for SSL renewal processes
  2. Improved early warning system for similar infrastructure issues
  3. Updated incident response procedures (new SOP)
  4. Additional automated health checks

We apologize for any disruption this caused and continue working to improve our infrastructure reliability.

Posted Jan 22, 2025 - 10:11 PST

Resolved

This incident has been resolved.
Posted Jan 22, 2025 - 07:37 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2025 - 07:33 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 22, 2025 - 07:27 PST

Investigating

We are currently investigating this issue.
Posted Jan 22, 2025 - 07:08 PST
This incident affected: Coveralls.io Web and Coveralls.io API.