Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Intermittent 502 (Bad Gateway) errors
Incident Report for Coveralls
Resolved
After another two (2) hours of monitoring without further incident, we are considering this matter resolved.

Again, if you happen to experience a 502 (Bad Gateway) error response from the Coveralls API, please reach out and let us know at: support@coveralls.io.
Posted Jan 11, 2024 - 14:51 PST
Monitoring
While we have not identified a root cause on our side, we have received no further reports of these `502` errors, and have not seen any additional production errors at the associated endpoint for 2 hrs, so we will move this to "monitoring."
Posted Jan 11, 2024 - 12:42 PST
Update
We have stopped receiving new reports of these `502` errors, and still have not identified an organic cause internally, so we are hoping that this was a temporary issue with a related service.

We will keep this open until we feel confident there are no further incidents.

If you experience any such errors, please reach out to: support@coveralls.io.
Posted Jan 11, 2024 - 12:27 PST
Update
We are still investigating but have not found any underlying errors in production logs for reported requests, pointing to possible latency issues with our edge service provider, Cloudflare.

No reported outages at Cloudflare, but two US centers (Salt Like City and Houston), are in maintenance mode and may be re-routing requests, adding to latency:
https://www.cloudflarestatus.com/
> Traffic might be re-routed from this location, hence there is a possibility of a slight increase in latency during this maintenance window for end-users in the affected region.
Posted Jan 11, 2024 - 09:43 PST
Investigating
Some customers are receiving sporadic `502` Bad Gateway errors from the Coveralls API in response to posts to `/api/v1/jobs`. We are investigating.
Posted Jan 11, 2024 - 09:11 PST
This incident affected: Coveralls.io API.