Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Degraded web performance & slower than normal builds
Incident Report for Coveralls
Resolved
Resolving this incident as we enter our maintenance window from 10p US PST to 2a US PST.
Posted Jun 30, 2022 - 22:00 PDT
Monitoring
We have a performance issue rooted in our database, which, to resolve, will take several full maintenance activities with downtime. We tried to do so last night without luck due to time needed. We have scaled infrastructure to its maximum useful size to manage the current issue, but we will need to complete the full maintenance to return performance to normal. That will require additional planned maintenance window tonight from 10p-2a US PST.

This incident will remain open all of today as we monitor the situation until the next maintenance window.
Posted Jun 30, 2022 - 09:00 PDT
This incident affected: Coveralls.io Web.