Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

504 Gateway Timeouts (Resolved)

Incident Report for Coveralls

Resolved

We are closing this incident having received no further reports of 504 errors today. We will continue to monitor for them.
Posted Oct 24, 2025 - 14:54 PDT

Monitoring

We received reports of 504 Gateway Timeouts from our Web Servers (coverage report uploads) between 6:00am-6:20am PDT and several moments ago between 11:15am-11:30am PDT.

We have recovered service to all web servers and are monitoring for further occurrences.
Posted Oct 24, 2025 - 11:35 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.