Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page Any time you notice a problem with coveralls

Slow performance due to high traffic
Incident Report for Coveralls
Resolved
This incident has been resolved. Background job queues 100% cleared.
Posted Nov 11, 2021 - 06:18 PST
Update
Background job queues are 50% cleared. We are continuing to monitor.
Posted Nov 10, 2021 - 17:22 PST
Update
Background job queues stand at 33% cleared. We are continuing to monitor.
Posted Nov 10, 2021 - 16:03 PST
Update
We have cleared ~20% of enqueued background jobs. Continuing to monitor.
Posted Nov 10, 2021 - 13:41 PST
Monitoring
We have taken measures to clear background job queues as quickly as possible and are monitoring status.
Posted Nov 10, 2021 - 12:28 PST
Investigating
Some users are experiencing slow build times due to traffic on shared resources. We may pause some repos with unusually high use of shared processing resources and temporarily increase processing resources to help clear background queues.

If you are experiencing slow PR status checks or comments, or receiving 0% coverage and/or a "DataTables" error on your build page for a recent build, please know that these are all effects of slow performance (delayed processing) and that we are attempting to address these issues with our current efforts.

Rest assured that if you received a 200 success response in your CI build log, your job(s) will eventually complete, your build page will fully render and you will receive PR status checks and comments.
Posted Nov 10, 2021 - 11:32 PST
This incident affected: Coveralls.io Web and Coveralls.io API.