Coveralls is in Read Only mode while we work on updating the system. Sorry for the inconvenience.

VIGILANCE! Check this page any time you notice a problem with coveralls

Unschedule maintenance

Incident Report for Coveralls

Resolved

This incident has been resolved.
Posted May 10, 2026 - 08:11 PDT

Investigating

We are currently investigating an issue with an apparently expired SSL cert. Our orchestration layer shows no issue with certs so we need to dig deeper.
Posted May 10, 2026 - 07:44 PDT
This incident affected: Coveralls.io Web and Coveralls.io API.