We had to pause some queues to recover performance for new jobs, but will clear those as soon as we've recovered normal build times for new jobs (ETA: 15-min).
If you are a user in APAC or EU, you may have had your jobs paused. One repo in particular has represented 90% overnight workload. We will reach out to that user.
Posted Dec 19, 2025 - 07:24 PST
Monitoring
We are continuing to monitor as we scale to clear backlogged jobs.
Posted Dec 19, 2025 - 06:52 PST
Identified
We are continuing to experience elevated latency in APAC and EU.
Posted Dec 19, 2025 - 06:34 PST
This incident affected: Coveralls.io Web and Coveralls.io API.